AcuFill Deactivation down

Incident Report for GBG

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 20:25 BST

Investigating

We are currently investigating this issue.
Posted Sep 08, 2025 - 20:01 BST
This incident affected: On Prem Licensing (AcuFill Activation Server).