Service Incident for - GreenID - DVS - Medicare Card, DVS - Australian Passport, DVS - Medicare Card

Incident Report for GBG

Resolved

This incident has been resolved.

Start Date and Time
17 April 2026 — 2:49AM AEST

End Date and Time
17 April 2026 — 6:26AM AEST
Posted Apr 17, 2026 - 00:16 BST

Investigating

We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Apr 16, 2026 - 20:46 BST
This incident affected: GreenID (DVS - Australian Passport, DVS - Medicare Card).