Service has been restored. We apologise for any disruption this may have caused.
Posted Apr 07, 2025 - 04:59 BST
Identified
We are investigating an issue affecting our GBG Trust service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. A further update and estimated resolution time at *05:30AM*
Posted Apr 07, 2025 - 04:35 BST
This incident affected: GBG ID3global (Trust Core (0411)).