GBG Go Testing

Incident Report for GBG

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 15:52 BST

Investigating

GBG Go Testing
Posted May 28, 2026 - 15:28 BST
This incident affects: GBG Test (Test 1 - GBG Go).