Service Disruption - ID3global / 0259 - South Africa Population
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 17:29 – 19:35 BST 25/05/2023
Posted May 26, 2023 - 07:10 BST
Identified
Our supplier has advised that they are currently experiencing technical issues and their service is likely to go down in the next 30 minutes.

They currently do not have an ETA for when the service will be restored.

This will mean disruptions to our service. We apologies for any inconvenience this may cause.
Posted May 25, 2023 - 17:53 BST
This incident affected: GBG ID3global (South Africa Population (0259)).