Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2024 - 16:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
This is routine maintenance by our data supplier.
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Jul 31, 2024 - 16:09 BST
This scheduled maintenance affected: GBG ID3global (International Adverse Media (0332), International PEP - FCRA (0308), International Sanctions - FCRA (0307)).