Service Disruption - 0154 - UK Credit Header (Identity) / 0155 - UK Credit Header (AML)
Incident Report for GBG
Resolved
Service was restored at approximately 17:30 GMT.

We apologise for any inconvenience caused.
Posted Jan 16, 2023 - 19:12 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jan 16, 2023 - 16:53 GMT
This incident affected: GBG ID3global (UK Credit Header (0154/0155)).