Service Incident for ID3global - South Africa Population (0259)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 04:56 GMT 13/01/23 – 13:43 GMT 17/01/23
Posted Jan 26, 2023 - 13:46 GMT
Update
Our supplier is continuing to work on fix for this issue and service will remain unavailable at present. We will update you as soon as we get any further information.

GBG Would like to apologise for any inconvenience caused.
Posted Jan 16, 2023 - 14:28 GMT
Update
Our supplier is currently working hard to fix this issue and have confirmed that unfortunately service will remain unavailable.

We will provide further updates as we get them.
Posted Jan 13, 2023 - 11:51 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jan 13, 2023 - 05:11 GMT
This incident affected: GBG ID3global (South Africa Population (0259)).