We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
The incident duration was between 19:25 BST – 20:15 BST BST DATE - 06/06/2025
Posted Jun 07, 2025 - 08:15 BST
Identified
Our supplier has made us aware of an ongoing issue that is effecting this item check. They are actively investigating this issue, however in the mean time you may see a degraded level of performance when attempting to use this item check. We hope to bring you confirmation of the resolution as soon as possible.
Posted Jun 06, 2025 - 20:00 BST
This incident affected: GBG ID3global (Austria Financial (0252)).