AcuFill Activation Server is down - 504 Error
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use AcuFill Activation Server services as normal.

To customers that have been affected by this issue, we would again like to apologize.
Posted Jun 04, 2024 - 20:29 BST
Investigating
We are currently investigating this issue.
Posted Jun 04, 2024 - 20:08 BST
This incident affected: On Prem Licensing (AcuFill Activation Server).