False Alarm! Degraded Service - ID3global / UK Mobile Fraud Indicators (0402)
Incident Report for GBG
Resolved
False Alarm! An internal process identified a potential customer-affecting issue. Upon further investigation, an alert was triggered unnecessarily. We apologise for any concerns or inconvenience this may have caused.
Posted Feb 01, 2024 - 11:08 GMT
Update
We are continuing to work on a fix for this issue.
Posted Feb 01, 2024 - 09:33 GMT
Identified
We are currently experiencing a degraded service that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jan 31, 2024 - 17:43 GMT
This incident affected: GBG ID3global (UK Mobile Fraud Signals (0402)).