Please be advised we have rescheduled this maintenance activity to next week as the Trust service will need to be taken down during this window. We apologise in advance for any inconvenience caused.
If you have any questions, please contact GBG Customer Support.
Posted Aug 06, 2025 - 11:42 BST
Scheduled
Dear Customer,
Please be aware that we are undertaking maintenance activities during the stated date and time. We are anticipating a degradation to the service for a short period during this window.
We apologise in advance for any inconvenience caused.
If you have any questions, please contact GBG Customer Support.
Posted Aug 06, 2025 - 11:04 BST
This scheduled maintenance affects: GBG ID3global (Trust Core (0411)).