This incident has been resolved Start Date and Time17/11/2025 16:18 AEDT Start Date and Time17/11/2025 17:45 AEDT
Posted Nov 17, 2025 - 22:49 GMT
Investigating
Our supplier is currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your business and we’re working with our supplier to get this back up and running.
Posted Nov 17, 2025 - 05:50 GMT
This incident affected: GBG Cloudcheck (Australian Citizenship, Australian ImmiCard, Australian Visa).