GBG Test Service disruption

Incident Report for GBG

Update

We are continuing to investigate this issue.
Posted Jun 08, 2026 - 16:23 BST

Update

We are continuing to investigate this issue.
Posted Jun 08, 2026 - 16:22 BST

Investigating

Test Service disruption
Posted Jun 08, 2026 - 16:22 BST
This incident affects: GBG Test (Test 2 - GBG Loqate).