Notification of Planned Supplier Maintenance - KYC6 and API Services (0397, 0398 & 0399)
Scheduled for Dec 11, 05:00 - 07:00 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 27, 2023 - 08:12 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.

During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Oct 05, 2023 - 16:23 BST
This scheduled maintenance affects: GBG ID3global (On-going Monitoring (0397), Global Sanctions (0398), Global PEP (0399)).