Service Disruption - Loqate - All Services - Increased Latency/Timeout Errors
Incident Report for GBG
Postmortem

Detailed root cause analysis investigations with GBG support teams confirmed this was caused by an increase in customer request exceptions during Black Friday which in-turn caused increases in latency to Loqate services. As a workaround, additional web servers were introduced to meet increased demand, before support teams then implemented load balancing configuration changes to the webservers to restore service.

Posted Dec 06, 2022 - 13:23 GMT

Resolved
19:30 UK time resolved
GBG are pleased to confirm that this incident has now been resolved and latency has reduced to expected levels. Support teams are continuing to work on the root cause and preventative actions. GBG would like to apologise for any impact caused whilst we worked to resolve this.
Posted Nov 25, 2022 - 20:52 GMT
Update
Work is still ongoing to fully resolve the issue.
Posted Nov 25, 2022 - 19:34 GMT
Update
Following previous measures implemented by GBG support teams, latency across Loqate services has significantly improved. Work is ongoing to fully resolve this with enhanced monitoring still in place. GBG would like to thank you for your patience whilst we work to resolve this
Posted Nov 25, 2022 - 18:40 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 25, 2022 - 18:39 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 25, 2022 - 17:37 GMT
Update
GBG support teams have implanted additional measures and service has now stabilised with enhanced monitoring in place. Further updates to follow.
Posted Nov 25, 2022 - 16:42 GMT
Identified
Start 14:13 UK GMT

Please be advised that GBG Support teams have identified a small increase in average latency affecting some Loqate requests. All Loqate services are up and operational and action has been taken to improve the latency seen. Further updates to follow.
Posted Nov 25, 2022 - 15:35 GMT
This incident affected: Loqate (Capture V3, Capture V4, Verify, Email Validation, Phone Verification, Bank Verification, Geocoding, Everything Location, Find My Nearest, Account Section, AddressComplete, AddressComplete V4, Capture China, Verify China, Utilities Register - Gas).