Retrospective Service Disruption - Loqate – Multiple Services (US Region)

Incident Report for GBG

Postmortem

We experienced a service disruption due to an issue with our cloud provider, which affected some of our services for a short period. We understand the inconvenience this may have caused and sincerely apologise for any impact on your operations. We are working closely with our provider and have already begun implementing several actions to reduce the risk of similar incidents in the future. Thank you for your patience and continued support.

Posted Aug 06, 2025 - 10:37 BST

Resolved

Please be advised that you may have experienced an intermittent service disruption that may have prevented you from using our service. The impact of this issue was localised only to US regions.

The incident duration was between 06/08/2025 03:35 BST – 06/08/2025 04:58 BST

To customers that have been affected by this issue, we would like to apologise and If you need to speak to us regarding this notification, please contact Customer Support via loqatesupport@gbgplc.com
Posted Aug 06, 2025 - 09:09 BST
This incident affected: Loqate (Capture V3, Capture V4, Verify, Loqate SaaS Platform, Email Validation, Phone Verification, Geocoding, Everything Location, Find My Nearest, Account Section, AddressComplete, AddressComplete V4, Store Finder - Geocoding, Store Finder - Distances, Store Finder - Mapping, Store Finder – List Management).