Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 00:00 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 12, 2024 - 09:29 GMT
Scheduled
Dear Customer,
We will be making a small change to our ID3global user interface, that we would like to make you aware of. We are adding a Single Sign on button on ID3global.
From the 14th of November you will be able to see a new button on Pilot. From the 19th of November you will be able to see a new button on LIVE.
This only affects customers who use Single Sign On as part of your integration with GBG.
If you do not use SSO, you can ignore this feature, if you have any queries about this, please reach out to your Customer Success Manager.
Kind regards, ID3global Product team
Posted Nov 01, 2024 - 09:42 GMT
This scheduled maintenance affected: GBG ID3global (ID3global Portal).