Service Disruption - ID3Global - China National ID (0361)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was approx. 07:51 till 23:44 BST on 22/06/2020
Posted Jun 23, 2020 - 02:41 BST
Update
Unfortunately we are still experiencing a service disruption that may be preventing you from processing transactions on our China National ID Service. Thank you for your patience whilst we work with our supplier to restore service.
Posted Jun 22, 2020 - 18:04 BST
Update
We are continuing to work on a fix for this issue.
Posted Jun 22, 2020 - 14:58 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jun 22, 2020 - 11:44 BST
This incident affected: GBG ID3global (China National ID (0361)).