Retrospective Service Disruption - greenID - Passport (DVS)

Incident Report for GBG

Resolved

Please be advised that we experienced a service disruption that may have prevented you from processing transactions against the following item check

Australian Passport (DVS)

Start Date and Time = 9 June 2025 — 7:45PM AEST

End Date and Time = 9 June 2025 — 10:05PM AEST

Issue is now resolved.
Posted Jun 10, 2025 - 00:49 BST
This incident affected: GreenID (DVS - Australian Passport).