Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2024 - 07:00 BST
Scheduled
Please be advised that GBG Support teams will be performing essential database maintenance at our US datacentre during this time. All core Loqate services will remain up and operational, however, Americas-based customers may experience some minor disruption to Verify whilst this takes place. This maintenance is vital to ensure the stability and reliability of Loqate services in the lead-up to the Black Friday trading period.
Posted Oct 21, 2024 - 11:00 BST
This scheduled maintenance affected: Loqate (Verify).