Service Disruption - greenID - DVS Production Citizenship
Incident Report for GBG
Resolved
Service restored.
Posted Jun 18, 2020 - 01:29 BST
Investigating
We are currently experiencing intermittent disruption from DVS - Citizenship data source that may be preventing you from using our service.

The next update will be provided when new information becomes available.
Posted Jun 17, 2020 - 00:51 BST
This incident affected: GreenID (DVS - Citizenship Certificate / Registration by Descent).