Service Disruption - greenID Web component
Incident Report for GBG
Postmortem

GreenID Incident Report

Ultimate Root Cause
The issue occurred due to internal migration of web application firewall (WAF). There was a configuration difference between the old and new firewall which caused the web request to fail. (Migration of firewall was informed in advance in status page: https://www.gbgstatus.com/incidents/dlpb4wc991hp))
We have made changes to the configuration of new firewall to fix the issue.

Fix Action
Modified the configuration for new firewall (to match the behavior of previous firewall) and pushed out an emergency release to deploy.

Preventative Action

This incident was caused by the Web Application Firewall migration. This is a significant infrastructure change which is not planned to recur anytime in near future. Prescribed actions are:

To process (changing existing or establishing new):
• GBG to issue reminder notification on the day of major or significant changes.
• Customer to subscribe to status page https://www.gbgstatus.com/

Posted Aug 06, 2020 - 00:54 BST

Resolved
Date of Incident: 03 Aug 2020 from 12:30 pm AEST
Customer: All customers utilising greenID-web
Product Line Impacted: greenID-web component

Downtime encountered?
greenID-web unavailable for approx. 3hrs between 12:30 pm - 15:30 pm AEST

Issue:
greenID web was unavailable for all customers whom utilise the greenID service
Posted Aug 02, 2020 - 18:30 BST