We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
Our supplier has identified where the underlying issue was and has just confirmed that this has recently been corrected. We have reviewed the results coming back for our customers and can confirm that this issue has been resolved.
The incident duration was between 11:24 21.05.2025 BST - 11:50 27.05.2025 BST
We apologies for any inconvenience caused at this time and are continuing to work with our supplier to avoid such re-occurrence of this issue.
Posted May 27, 2025 - 13:12 BST
Update
We want to acknowledge that the service issue you have reported has now been ongoing for over five days, and we deeply understand the inconvenience this may be causing. Please accept our sincerest apologies for the continued disruption.
Our team is actively working to resolve this issue and is in direct communication with our data provider to identify the root cause and accelerate a solution. Currently, the issue is impacting the accuracy of name matching in item checks, which has led to a noticeable decrease in match rates.
Although resolving this fully requires external support, we want to assure you that this matter is receiving our highest priority. We will continue to share updates as soon as we have more definitive information.
Thank you for your patience and understanding during this time. If you have any questions or require assistance, please do not hesitate to reach out to us.
Posted May 27, 2025 - 11:05 BST
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2025 - 10:32 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 26, 2025 - 16:45 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 26, 2025 - 10:32 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 25, 2025 - 09:41 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 24, 2025 - 18:29 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 24, 2025 - 15:30 BST
Update
Our data supplier is continuing to work on a fix for this issue. Thank you for your patience.
Posted May 24, 2025 - 12:29 BST
Update
We are awaiting further updates from our data supplier regarding implementing a fix for this issue. Thank you for your patience.
Posted May 24, 2025 - 09:30 BST
Update
We are awaiting further updates from our data supplier regarding implementing a fix for this issue. Thank you for your patience.
Posted May 23, 2025 - 20:02 BST
Identified
We are aware of an issue impacting the results generated from item checks. Our supplier has identified that this is affecting the accuracy of name matching, resulting in a reduction in the matching percentages experienced by our customers. Please rest assured that the supplier is actively investigating the matter and working diligently towards a resolution.
Posted May 23, 2025 - 16:53 BST
This incident affected: GBG ID3global (UK Credit Header (0154/0155)).