Service Incident for ID3global - Australia Property (0302)
Incident Report for GBG
Resolved
We have investigated with the data supplier and have confirmed this was due to scheduled maintenance which we have not notified customers of via our status page.

Please accept our apologies for any inconvenience caused by this maintenance.
Posted Mar 11, 2023 - 10:21 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 11, 2023 - 09:30 GMT
This incident affected: GBG ID3global (Australia Property (0302)).