Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2025 - 20:00 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier. During the date/time specified, services will be unavailable.
Posted Jan 27, 2025 - 13:59 GMT
This scheduled maintenance affected: GBG Loqate (Matchcode360) Platform (Loqate (Matchcode360) Land Registry), GBG Connexus Platform (Connexus Land Registry), and GBG Investigate (Land Registry - Extract Service, Land Registry - Online Ownership Verification).