Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 14, 2025 - 14:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier (illion)
Maintenance Window: Wednesday 15th October 00:00 AEDT to Wednesday 15th October 02:00 AEDT ·
Outage Duration: Up to 15 minutes
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Oct 10, 2025 - 02:51 BST
This scheduled maintenance affected: GreenID (ASIC Personal Name Search, illion Australian Credit Header, Australian Tenancy File, Data Co-Op Database, FCS Public Number Directory, FCS NAD File, NZTA NZ Drivers Licence, illion NZ Credit Header, FCS illion Data Sources, NZ Personal Property Securities Register (PPSR), Segmented Illion Credit Header Data (AU), Segmented Illion Credit Header Data (NZ), NZ illion Tenancy (FCS)).