Service Disruption - ID3 Malaysia Financial (0354)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was Approx between 15:15 – 21:00 BST 04/04/2021
Posted Apr 05, 2021 - 02:13 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Apr 04, 2021 - 19:07 BST
This incident affected: GBG ID3global (Malaysia Financial (0354)).