Service Incident for Loqate - Utilities Register - Electricity

Incident Report for GBG

Resolved

This incident has been resolved.
Posted Feb 15, 2025 - 18:03 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 15, 2025 - 18:02 GMT

Identified

We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Feb 15, 2025 - 15:42 GMT
This incident affected: Loqate (Utilities Register - Electricity).