Service Disruption - ID3 Global / Australia Credit (0298), Australia Historical Electoral Roll (0299), Australia Electoral Roll (0300), Australia Telephone (0301) & Australia Property (0302)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 15:05-17:27 BST 30/07/2022
Posted Jul 30, 2022 - 18:06 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jul 30, 2022 - 16:17 BST
This incident affected: GBG ID3global (Australia Credit (0298), Australia Electoral Roll (0300), Australia Historical Electoral Roll (0299), Australia Passport (0303), Australia Property (0302), Australia Telephone (0301)).