Acuant Activation Server down (404 Error)
Incident Report for GBG
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 20:36 GMT
Investigating
We are currently investigating this issue.
Posted Nov 22, 2024 - 20:33 GMT
This incident affected: On Prem Licensing (AcuFill Activation Server).