Service Disruption - ID3Global - Ireland Voter (0205)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 12.32 – 07.13 GMT 17/ 03/2019 - 18/ 03/2019
Posted Mar 18, 2020 - 10:41 GMT
Update
We are continuing to resolve this issue.
Posted Mar 18, 2020 - 09:00 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2020 - 16:02 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 17, 2020 - 13:08 GMT
This incident affected: GBG ID3global (Ireland Voter (0205)).