Service Disruption - greenID Admin Panel (Test ONLY)

Incident Report for GBG

Resolved

Please be advised that the issue affecting the greenID admin panel (Test Only) has been resolved.
Posted Aug 28, 2025 - 01:35 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 01:24 BST

Investigating

We are currently experiencing a service disruption that may be preventing you from using greenID admin panel (Test Only).

The greenID technology team are working to restore services.

The next update will be provided when new information becomes available.
Posted Aug 28, 2025 - 00:40 BST
This incident affected: GreenID (GreenID Admin Panel).