Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 09:30 GMT
Scheduled
Dear Customer,
This notification is to inform you of maintenance activities taking place during the stated date and time.
As part of our routine maintenance, we’ll be renewing a security certificate to keep our services secure and up to date.
There is no expected impact on service availability, and no action is required from customers.
Any questions, please contact GBG Customer Support.
Posted Dec 04, 2025 - 16:57 GMT
This scheduled maintenance affected: Loqate (Capture V3, Capture V4, Verify, Loqate SaaS Platform, Email Validation, Phone Verification, Bank Verification, Geocoding, Everything Location, Find My Nearest, Account Section, AddressComplete, AddressComplete V4, Utilities Register - Gas, Utilities Register - Electricity, Store Finder - Geocoding, Store Finder - Geocoding Typeahead, Store Finder - Distances, Store Finder - Mapping, Store Finder – List Management, Capture Legacy).