Service Disruption GBG Trust (0411)

Incident Report for GBG

Resolved

We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 00:19 – 09:45 BST 17/04/2025
Posted Apr 17, 2025 - 09:58 BST

Update

We are continuing to investigate this issue.
Posted Apr 17, 2025 - 08:36 BST

Investigating

We are aware of an issue impacting GBG Trust. We are currently investigating.
Posted Apr 17, 2025 - 02:24 BST
This incident affected: GBG ID3global (Trust Core (0411)).