Service Incident for Loqate - Utilities Register - Gas MPRN Check
Incident Report for GBG
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 07:57 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 15, 2024 - 00:04 GMT
This incident affected: Loqate (Utilities Register - Gas).