Service Disruption - 0261 - UK Bank Account Verification
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to complete transactions as normal.

To customers that have been affected by this issue, we would again like to apologise.
Posted Dec 31, 2021 - 12:19 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Dec 31, 2021 - 10:29 GMT
This incident affected: GBG ID3global (UK Bank Account Verification (0261)).