Service Incident - greenID - Hosted / Biometric / Scan (Prod Environment)

Incident Report for GBG

Update

We are continuing to investigate this issue.
Posted Jun 03, 2026 - 02:45 BST

Investigating

We’re currently experiencing degraded performance, which may result in slower-than-usual response times when using our service. While the service remains available, some features may not perform as expected.
We’re sorry for the impact this may be having on your business and we’re working hard to get this back up and running.
Posted Jun 03, 2026 - 02:41 BST
This incident affects: GreenID (GreenID Biometric / Scan).