Service Disruption - greenID - DVS Production Driver Licence
Incident Report for GBG
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 23:37 BST
Investigating
Dear Valued Customer,

The greenID technology team advises on behalf of our partner, DVS that Driver Licence checks are currently unavailable unexpectedly.

Resolution time is currently unknown. The greenID technology team await further advice from DVS.

The next update will be provided when new information becomes available.
Posted Oct 05, 2020 - 23:18 BST
This incident affected: GreenID (DVS - Driver Licence (All States)).