Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2025 - 12:15 BST
Scheduled
Dear Customers,
After yesterday's maintenance event, the Support Teams have identified a corrective action requires implementing to prevent future service degradation. We are anticipating less than 5 minutes downtime of service during this work.
We apologise for any inconvenience caused.
Posted Oct 02, 2025 - 12:09 BST
This scheduled maintenance affected: GBG ID3global (Trust Core (0411)).