Service Disruption - ID3global Ireland Voter check
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 11:45 25/03/2020 – 09:50 GMT 26/03/2020
Posted Mar 26, 2020 - 11:57 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2020 - 09:33 GMT
Update
We are continuing to work on a fix for this issue with our platform team and data supplier. As soon as there are further updates we will provide them.
Posted Mar 25, 2020 - 17:00 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 25, 2020 - 14:02 GMT
This incident affected: GBG ID3global (Ireland Voter (0205)).