Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 2 years ago. Nov 18, 2023 - 14:00 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Start time: Saturday, Nov 18, 2023, 23:00 Sydney Australia time Estimated finish time: Sunday, Nov 19, 2023, 07:00 Sydney Australia time Estimated Duration: 8 hours
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted 2 years ago. Sep 14, 2023 - 01:08 BST
This scheduled maintenance affected: GreenID (Experian Australian Credit Header).