Service Disruption - GBG Investigate Landline Validation
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 14:29 – 17:13 BST 12/10/2021
Posted Oct 12, 2021 - 17:21 BST
Update
Our platform team are working with our hosting provider on a resolution for this issue.
Posted Oct 12, 2021 - 15:44 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Oct 12, 2021 - 14:35 BST
This incident affected: GBG Investigate (Landline Validation).