Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2025 - 10:00 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Super and Payroll - Superannuation data source & Payroll data source Outage Schedule Tuesday, November 18th from 8pm to 11pm (AEDT)
During this maintenance window, Super and Payroll data sources will be unavailable. We recommend planning ahead to minimise any disruption to your operations.
Posted Nov 06, 2025 - 04:02 GMT
This scheduled maintenance affected: GreenID (Super and Payroll - Superannuation data source, Super and Payroll - Payroll data source).