Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2024 - 23:00 BST
Scheduled
Please be advised that our supplier will undertaking essential maintenance today to improve the resiliency and reliability of the service. If you are using the service during the times stated, you may experience some short periods of disruption. All other services will remain unaffected.
Posted Sep 12, 2024 - 15:28 BST
This scheduled maintenance affected: Loqate (Phone Verification) and Loqate for Australia and New Zealand (Harmony RightAddress) (Phone Validation (ANZ)).