Service Disruption - greenID - Work Visa (Non-Dvs / VEVO)
Incident Report for GBG
Resolved
Service restored.
Posted Sep 04, 2020 - 00:46 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2020 - 06:55 BST
Investigating
Dear Valued Customer,

We are currently experiencing service disruption for Work Visa Check source (VEVO) that may be preventing you from using our service.

The next update will be provided when new information becomes available.
Posted Aug 28, 2020 - 01:09 BST
This incident affected: GreenID (Working Visa - VEVO).