Service Incident for ID3global - UK Births Index (0133)
Incident Report for GBG
Resolved
This alert was triggered by GBG internal testing. There was no impact to the UK Birth Index (0133) item check.
Apologies for any confusion this alert may have caused.
Posted Apr 15, 2024 - 07:59 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Apr 15, 2024 - 05:01 BST
This incident affected: GBG ID3global (UK Births Index (0133)).