Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2025 - 16:00 GMT
Scheduled
Please note that during periods of high demand in Loqate over the coming week, you may notice that some of the usage information does not update in real time. Usage data will automatically reconcile after the peak times. This is expected and will not impact transaction processing or account access.
You do not need to take any action.
Posted Nov 21, 2025 - 15:49 GMT
This scheduled maintenance affects: Loqate (Account Section).