We are pleased to confirm that this incident was resolved at 21:00 UTC+1 today.
Thank you for your patience.
Posted Jul 08, 2025 - 23:04 BST
Update
We are continuing to work on the fix for this issue.
Posted Jul 08, 2025 - 18:32 BST
Update
We are continuing to work on a fix for this issue.
Posted Jul 08, 2025 - 15:30 BST
Update
Our data supplier is continuing to investigate this incident and we will provide an update as soon as available.
Posted Jul 08, 2025 - 12:30 BST
Update
The incident is still ongoing with our data supplier and is currently still being investigated. Further updates will be provided as soon as they are available.
Posted Jul 08, 2025 - 09:30 BST
Update
We are continuing to work on a fix for this issue.
Posted Jul 07, 2025 - 18:37 BST
Update
The incident is still ongoing with our data supplier and is currently still being investigated. Further updated will be provided as soon as they are available.
Posted Jul 07, 2025 - 15:40 BST
Update
We are continuing to work on a fix for this issue.
Posted Jul 07, 2025 - 12:34 BST
Update
Our data supplier is continuing to investigate this incident and we will provide an update as soon as available.
Posted Jul 07, 2025 - 09:31 BST
Update
We are continuing to work on a fix for this issue.
Posted Jul 06, 2025 - 18:40 BST
Update
We are continuing to work on a fix for this issue.
Posted Jul 06, 2025 - 09:24 BST
Update
We are continuing to work on the fix for this issue.
Posted Jul 05, 2025 - 18:12 BST
Update
Our data supplier is continuing to investigate and working on a fix for this incident.
Apologies for the inconvenience caused.
Posted Jul 05, 2025 - 15:07 BST
Update
We are continuing to investigate this issue.
Posted Jul 05, 2025 - 13:03 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jul 05, 2025 - 09:01 BST
This incident affected: GBG ID3global (Peru Identity (0520)).