Service Disruption - ID3 UK Mobile Fraud Signals (0402)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 17:30 GMT 17/11/2022 – 19:15 GMT 22/11/2022
Posted Nov 22, 2022 - 19:55 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Nov 22, 2022 - 17:15 GMT
This incident affected: GBG ID3global (UK Mobile Fraud Signals (0402)).